Login difficulties
Incident Report for Jostle-Platform
Resolved
The issue has been identified and resolved.
Posted Apr 19, 2024 - 14:42 EDT
Investigating
We are experiencing an issue with the Login button preventing some users from logging in. For now, the workaround is to use the incognito/private mode on the browser or clear cookies and cache. We are investigating.
Posted Apr 19, 2024 - 11:16 EDT