Jostle issue

Incident Report for Jostle-Platform

Resolved

As of 3:53 PT AWS has indicated the the incident is fully resolved.
Posted Oct 20, 2025 - 19:47 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 20, 2025 - 12:11 EDT

Investigating

We are currently investigating some loss of functionality on the platform.Our cloud provider AWS is experiancing issues that are affecting parts of JOstle's functionality. https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 12:07 EDT